Pages

Saturday, October 29, 2011

52

Prac's looping Picasa simple slideshow gadget

While I was developing my looping embedded Picasa slideshow, I was also searching for alternative slideshow viewers. I don't care too much about branding that appears in many slideshow services and gadgets. Then from Google Sites forum I found (nickname) prac's RSS slideshow gadget in this thread. Tried it, and it works very well in Blogger. Thank you prac, your gadgets are great.

I use the No Border version like this:

<iframe allowtransparency="true" frameborder="0" scrolling="no" width="600" height="420" src="http://www.gmodules.com/gadgets/ifr?url=https://googledrive.com/host/0B4yfJJJSNrfubzJEUkxIYm1PcHM/picasa-slideshow-simple-nb.xml&up_CCOL=%23FFFFFF&up_SCOL=%23FFFFFF&up_PWH=560&up_PHT=420&up_DTime=3000&up_TTime=400&up_CLP=Yes&up_FEED=http://picasaweb.google.com/data/feed/base/user/mspotilas.fi/albumid/5650715941079457233?alt=rss&amp;kind=photo&amp;hl=en_US"><a href="http://picasaweb.google.com/mspotilas.fi/KevatKesa?authuser=0&feat=directlink#slideshow">Gallery</a></iframe>
<!-- Gadget Google - Diaporama Picasa Albums Web - http://www.liens-du-vin.ch/picasa-gadget-script.htm -->

Red parts you want to change, they are the Picasa web album RSS feed and Picasa web album (#slideshow) url, in case iframe is not supported. You must change all & characters to &amp; in the feed url (but not in album url)! You can get the links from Picasa Web albums, from right side bar "Link to this album" (add #slideshow to it to make a slideshow link) and "RSS" (the feed). And remember to change those &:s in the RSS feed url.

Green parts you may want to change: dimensions, background colors, slide time, transition time, and link pictures to gallery or not. I use white background, 3 second slide time, 400 millisecond transition time, link pictures (up_CLP) to Picasa web album. More of the parameters here (in French).

You can see the above code embedded here in action:

[Hide comments] - [Show comments]
Click on a single comment to hide/show its text

52 comments:

Beben Koben said... [reply]

i'll have go there, blogger france very well...*just search on my box search blogger perancis*
but i still not understand about script...xixixixi :(

higutibordados said... [reply]

works fine firefox ,but it crash in Internet explorer .any ideas???

MS-potilas said... [reply]

@higutibordados
Hi, i tried it on IE when I posted this, and now again with my blogs and yours. Slideshows seemed to work ok, no crashes. If you still have problems, you might try to ask this in the Blogger forums, prac (who made this gadget) might answer and have some advice.

Michael said... [reply]

If I reload the page, the images in the slideshow appear to be shifted down and to the right, so I am only able to see the top-left corner of the picture (using Google Chrome).

Michael said... [reply]

Seems to be a problem only when using the Adblock extension...

@Michael

spike_h said... [reply]

That is a really great solution - but anyone got an idea to be able to add the Picasa captions as well

MS-potilas said... [reply]

@spike_h
Hi, I think prac's gadget "picasa-slideshow.xml" does that, although I haven't looked into it because I don't need the titles. There is one example on this prac's page (search for the word "suisses"). Image captions are shown below the slideshow.

prasujya said... [reply]

Its not working with Unlisted album link , any suggestion please .
Also how to stop the Autoplay function .

Thanks .

MS-potilas said... [reply]

@prasujya Hi, I think it should work with unlisted album, too, just get the RSS link from the right sidebar while viewing the album in Picasa Web.

I'm not sure, if autoplay can be stopped in this gadget. Here are instructions in English: http://sites.google.com/site/annuairevin/media-rss-feed-slideshow, but I did not find any parameter for that.

steph said... [reply]

is there a way to include thumbnails with the slideshow?

MS-potilas said... [reply]

@steph No, I'm afraid it is not possible with this gadget. Try googling for example with keywords "free rss slideshow", I think there are many with thumbnails, too, but I have not tried any.

Tim said... [reply]

Hi, I have found that the sildeshow I embedded does not update when I make changes to the designated album. What am I doing wrong?

MS-potilas said... [reply]

@Tim Hi, I have not noticed that behaviour. My guess is that browser caches the RSS feed for some time, and the contents won't update until cache expires.

Dennis Klaustermeyer said... [reply]

Hi...was wondering if there is a way to make this work now that everything is https with Picasaweb? Thank you.

MS-potilas said... [reply]

@Dennis Klaustermeyer Hi, I think it will work if you just change the https to http in the urls.

Dennis Klaustermeyer said... [reply]

I did try that but am getting an error. Maybe I have something wrong in my code. I'll try posting in forums and see if I can get an answer. Thanks!@MS-potilas

Girl Friday said... [reply]

I really love this show. It's working great for me and I removed the link back to the Picasa album, which I don't want.

But is there some way to insert a link for each picture so a viewer can click on the picture and go to another page on my site?

Or is there some other way to do it with another type of Picasa slideshow or Photobucket, etc.?

Laura

Paul said... [reply]

Hi, I think you need to use a public album.

@Dennis Klaustermeyer

Kirsten Wollschlager said... [reply]

I have tried to use this pasting my own Rss and Direct Link into the appropriate places.... and I get an unkown error. I did change all of the &'s on the RSS. Any suggestions anyone?

SoylentGreen said... [reply]

@Girl Friday: How did you remove the link back to Picasa? I also want to remove it.

MS-potilas said... [reply]

@SoylentGreen
Hi, there is parameter up_CLP=Yes, change that to up_CLP=No.

David Kutcher said... [reply]

If you'd like to give a non-Flash and fully customizable Picasa slideshow a try, using JQuery, check it out here.

satyanarayannagar welfare assoceation said... [reply]

what a great work,you have done good job,i tried past one year,finally i got it thanks,to day i am very happy

Flo said... [reply]

lingFAHi guys.... I have noticed that the slideshow behaves a bit awkward when the page is opened in Google Chrome. Not all the time. If anyone has a clue about it, it would be good to know. Ill keep an eye on it.

Lori Buff said... [reply]

@Kirsten Wollschlager

I suspect we need to add the xml and/or the java script that the author refers to but I'm not clear which or where.

Jaap Roodenburg said... [reply]

Great job, any idee how to get the text displayed in the foto ?

MS-potilas said... [reply]

@Jaap Roodenburg
Hi, prac has also done a gadget which does that, but I have not used it myself. Different versions of the gadget is listed on this page. I think it is the "picasa-slideshow.xml". Search for "avec titre" on the page to find the parameters, and an example.

Wes said... [reply]

Is there a way to make the order of pictures in the slideshow a random one?

MS-potilas said... [reply]

@Wes
Yes, add to the url after

&up_CLP=Yes

this:

&up_RND=Yes

JanC said... [reply]

i am having some right problems with this code of yours, your code as it is with your links works great but as soon as i add my links i get error message and when i check the code it is nothing like it was...seems blogger messes it all up or something!

All i wanted was this simple slideshow to play the photos in one album but it is not doing it for me in my blog...maybe something is interfering with it.

MS-potilas said... [reply]

@JanC
Hi, make sure you have all the code in one line, and your Picasa album is public. If those don't help, I don't know what could be wrong. I hope you get it working.

dsotherem said... [reply]

@MS-potilas

hi MS-potilas,

i can't seem to make this work for unlisted albums - is it possible

the issue seems to be with the & at authkey

i.e. i can change two of &s to &amps (except the &authkey) and the link is live:

http://picasaweb.google.com/data/feed/base/user/107980887203213427201/albumid/5854694088765236465?alt=rss&kind=photo&authkey=Gv1sRgCNzh85nu7OORVw&hl=en_US

but as soon as i change them all picasa says no album can be found and the gadget will not work as the link is not live:

http://picasaweb.google.com/data/feed/base/user/107980887203213427201/albumid/5854694088765236465?alt=rss&kind=photo&authkey=Gv1sRgCNzh85nu7OORVw&hl=en_US

any ideas, other than making the albums completely public?

MS-potilas said... [reply]

@dsotherem
Hi,

it should work, and seemed to work when I tried it. Here is the code:

<iframe allowtransparency="true" frameborder="0" scrolling="no" width="600" height="420" src="http://www.gmodules.com/gadgets/ifr?url=http://prac-gadget.googlecode.com/files/picasa-slideshow-simple-nb.xml&up_CCOL=%23FFFFFF&up_SCOL=%23FFFFFF&up_PWH=560&up_PHT=420&up_DTime=3000&up_TTime=400&up_CLP=Yes&up_FEED=http://picasaweb.google.com/data/feed/base/user/107980887203213427201/albumid/5854694088765236465?alt=rss&amp;kind=photo&amp;authkey=Gv1sRgCNzh85nu7OORVw&amp;hl=en_US"><a href="https://plus.google.com/photos/107980887203213427201/albums/5854694088765236465">Gallery</a></iframe>
<!-- Gadget Google - Diaporama Picasa Albums Web - http://www.liens-du-vin.ch/picasa-gadget-script.htm -->

Zomerzon said... [reply]

Hello
I am using the PRAC's Looping slideshow on a wordpress blog but I am encoutering the following problem. In CHROME the site jumps from slideshow to slideshow whenever a new picture shows up in any of the slideshows. I didn't used to be like that in CHROME in the past and the problem doesn't appear in Internet Explorer. Any idea what's wrong?

this is the site - try it in both explorers: http://exchange.classy.be

Yours
Filip

MS-potilas said... [reply]

@Zomerzon
Hi,

that sounds strange. I tried the page using Chrome and Firefox, but both worked. I'm using Ubuntu, so I cannot try Internet Explorer. Chrome version is 26.0.1410.43.

Maybe you have some extension in Chrome that causes the behavior? Or it may be a transient browser bug (fixed in next version). Can you try another computer with Chrome? Other than these, I'm out of ideas. Luckily it does not happen on all Chrome browsers (at least not on mine). Hope you get it solved. :)

Ratprincess said... [reply]
This comment has been removed by the author.
Ratprincess said... [reply]

I have tried to use this gadget... unfortunately, it doesn't want to go through all 602 pictures... Wonder whether you have any idea where the problem might be?

Hope you can help me get this issue resolved!

http://ratologydisabletrip.blogspot.tw/2013/06/fountain.html

MS-potilas said... [reply]

@Ratprincess
Hi, unfortunately I don't know. I suggest you contact the author of the gadget and ask him.

Ratprincess said... [reply]

Thanks... I tried but didn't hear back... lol@MS-potilas

The EntertainMix said... [reply]

THIS has been an absolute lifesaver!!! It is EXACTLY what I was looking for ALL day. It took me quite a while to figure it out and get it working the way I wanted but I finally got it.

Here is a tip that will hopefully save others time. My guess is that since this post was created years ago, there has been a change in the syntax used for the RSS url. Instead of base, it now says api. To solve this, simply look in the url for the word api and change it to base.

For example, my RSS url had this in it:

picasaweb.google.com%2Fdata%2Ffeed%2Fapi%2Fuser

So I changed that part to this:

picasaweb.google.com%2Fdata%2Ffeed%2Fbase%2Fuser

And voila!! I hope you can understand this and I hope it helps someone :)

Juanmi said... [reply]

Thank you man, your plugin is awesome!!!

Szabolcs Emod said... [reply]

seems i'm really dumb,
i have this gallery: https://picasaweb.google.com/103978276873611525029/Gallery?authkey=Gv1sRgCP6T1P_dvpPcJw i can found both link (directlink and RSS), but when i change them acordingly, i receive a gmodules.com Error undefined message.

an i have any help?

Ciupercomania said... [reply]

@Szabolcs Emod

yay, i managed to make it work with flickr

MS-potilas said... [reply]

@Szabolcs Emod
Hi, well we can be dumb together, as I got the same message when I tested your album's feed. Unfortunately I don't know why that feed does not work with the gadget. You could try to use some other album with the slideshow, and if it works, try copying images to a new album.

Lori Buff said... [reply]

This worked so nicely for several years, now I see the same 403 error on my page as you’re getting here. Back to the old drawing board.

MS-potilas said... [reply]

@Lori Buff
Hi,

I've updated the code to make it work again. Please change

http://prac-gadget.googlecode.com/files/picasa-slideshow-simple-nb.xml

to

https://googledrive.com/host/0B4yfJJJSNrfubzJEUkxIYm1PcHM/picasa-slideshow-simple-nb.xml

in your code, and it should work again, like it does on this page.

Unknown said... [reply]

Hi,

I found today that this gadget is no longer working. It's showing an error "This API is no longer available". Can anyone fix it? I have it all over my websites...

MS-potilas said... [reply]

@Unknown
Hi,

unfortunately a key API used by the gadget is no longer available and the slideshows don't work. The slideshow gadget is actually not made by me, only the instructions to use it. The gadget is made by nickname "Prac" from Google user forums. Here's a discussion about the terminated API:
https://productforums.google.com/forum/#!topic/sites/mss9kow7QJo
also Prac has commented (he hopes that Google fixes it). Hopefully Google or Prac will do something to fix the slideshows, which are used by many. Lets's keep our fingers crossed.

Post a Comment

Related Posts Plugin for WordPress, Blogger...
See the hack
for this dynamic
views icon: